Загрузка...

обратиться в техподдержку

Сохранение настроек внешней обработки 1С

Служба заботы
07 февраля 2024

Для сохранения будем использовать ХранилищеОбщихНастроек т.к. использование данного объекта 1с наиболее гибко

Функция сохранения настроек

 
// имя пользователя - пользователь владелец настроек, если параметр не указать,
// то настройки будут сохранены для ТЕКУЩЕГО пользователя
ИмяПользователя = ИмяПользователя();
ХранилищеОбщихНастроек.Cохранить(КлючОбъекта,  КлючНастроек, Настройки, , ИмяПользователя);

Процедура СохранитьНастройки(Настройки, ИмяНастройки) Экспорт
    // Создаем структуру для хранения настроек
    СтруктураНастроек = Новый Структура;
    СтруктураНастроек.Вставить("Настройки", Настройки);

    // Преобразуем структуру в строку
    СтрокаНастроек = СтруктураНастроек.ЗаписатьJSON();

    // Сохраняем строку в ХранилищеОбщихНастроек
    ХранилищеОбщихНастроек.Записать("ВнешняяОбработкаНастройки_" + ИмяНастройки, СтрокаНастроек);
    ХранилищеОбщихНастроек.Cохранить(КлючОбъекта,  КлючНастроек, Настройки, , ИмяПользователя);
КонецПроцедуры

Функция чтения настроек

 
Функция ПрочитатьНастройки(ИмяНастройки)
    // Читаем строку настроек из ХранилищеОбщихНастроек
    СтрокаНастроек = ХранилищеОбщихНастроек.Прочитать("ВнешняяОбработкаНастройки_" + ИмяНастройки);

    // Если настройка не найдена, возвращаем пустую структуру
    Если ПустаяСтрока(СтрокаНастроек) Тогда
        Возврат Новый Структура;
    КонецЕсли;

    // Преобразуем строку обратно в структуру
    СтруктураНастроек = Новый Структура;
    СтруктураНастроек.ПрочитатьJSON(СтрокаНастроек);

    // Возвращаем настройки
    Возврат СтруктураНастроек.Получить("Настройки");
КонецФункции

Эту и другие технические статьи написали наши программисты 1С и получили за них премии. Если вы тоже работаете с 1С и любите делиться опытом, приходите разработчиком в МИТ

Наши сервисы по этой теме:


заполните, пожалуйста
укажите Ваш e-mail
укажите Ваш номер телефона для связи